Иллюстрированный самоучитель по Flash-games



             

Требуемые версии


Обычно вам нужно сравнить номер версии с минимальными требованиями, необходимыми для игры. Например, вы можете задать минимальную версию, необходимую пользователю для вашей игры, 6.0.21.0. Вот функция, которая берет полный номер требуемой версии и сравнивает с номером версии, запушенной в настоящее время на компьютере пользователя. Она возвращает истинное значение только в том случае, если установленная версия больше или равна требуемой.

function requiredVersion(required) {

version = getVersionNumber();

// Возвращаем false, если номер версии меньше необходимого,

if (version.nl < required.nl) return(false);

// Возвращаем true, если номер версии больше необходимого,

if (version.nl > required.nl) return(true);

// Главные позиции номера совпадают, сравниваем следующие

// позиции.

if (version.n2 < required.n2) return (false);

if (version.n2 > required.n2) return (true);

if (version.n3 < required.n3) return (false);

if (version.n3 > required.n3) return (true);

if (version.n4 < required.n4) return (false);

if (version.n4 >= required.n4) return (true);

Вы можете использовать эту функцию так:

if (requiredVersion) ({nl: 6, n2: 0, пЗ: 21, п4:0})}

gotoAndPlay("start");

} else {

gotoAndStopt"version problem");}

ЕСЛИ версия пользователя меньше, чем 6.0.21.0, ролик переходит к кадру, который объясняет, что данная игра требует обновления версии плеера.

Все коды в функциях getVereionNumber и requiredVersion будут работать и с Flash бис Rash 6. Весь код ничего не будет стоить, если будет работать только с Flash 6. Идея состоит в том, чтобы предупредить пользователя Flash 5-плеера о возможных проблемах.

Обычное данную функцию предполагается использовать для того, чтобы обнаруживать небольшие обновления Flash-плеера. Предположим, например, что Macromedia выпускает Flash версии 6.0.42.0. Эта версия содержит исправление, которое необходимо для корректной работы вашей игры. Вы должны проверить, есть ли у пользователя данная версия, и предупредить его, если ее нет.
Важно, чтобы эта проверка возвращала true только в том случае, если у пользователя установлена требуемая версия или более новая. Обычная ошибка, которую делает программист, это поиск точного номера версии, например, 6. Тогда, если у пользователя установлена 5-я или любая другая версия, он получает предупреждение о необходимости обновления. Спустя год выходит версия 7, а поскольку версия 7 также не является версией 6, пользователь получает точно такое же предупреждение! Я постоянно сталкиваюсь с этим в программировании во Flash, Stockwave и JavaScript. Функция requiredVersion всегда возвращает true если версия пользователя более новая, чем требуемая.




Содержание  Назад  Вперед